PostgreSQL - PostGIS compatibility issues

Few days ago I wanted to update from PostgreSQL 9.1 to PostgreSQL 9.3, an action that initially should be easy (famous last words ;)
As I had also installed PostGIS 2.0, of course this ended in problems and errors. Luckily, I was able to find the solution after a lot of searching around the net and error-based trials, so let's see if this helps anybody.

First of all, if after updating PostgreSQL you try to recompile and reinstall PostGIS 2.0, you will probably get a similar error in the "make install" step:

ERROR: could not load library [...] undefined symbol: GETSTRUCT

What this error really tries to say is "your PostGIS version is outdated for this PostgreSQL version, please update".

Basically, PostgreSQL 9.3 requires PostGIS 2.1 (I installed 2.1.1).

And because history tends to repeat itself, there is a very handy compatibility chart between both software pieces at the PostGIS wiki.

Comments?

Posted by Kartones on 2014-04-03